Kerbal Space Program (PC/Mac) – R204.50 | Steam *Expired*

steam

Kerbal Space Program

Kerbal Space Program (PC/Mac)R204.50

In KSP you must build a space-worthy craft, capable of flying its crew out into space without killing them. At your disposal is a collection of parts, which must be assembled to create a functional ship. Each part has its own function and will affect the way a ship flies (or doesn’t). So strap yourself in, and get ready to try some Rocket Science!

Offer ends the 29/08/2016 at 7:00 PM SAST.

Facebooktwittergoogle_plusmail
  • Hey Lonthor,

    Just having a problem with only this site. It keeps getting stuck. So right now the main page is stuck on the 28th. The other pages work fine. It did this to me a month ago as well and I needed to delete cookies to get it working again.

    None of my other regular sites are misbehaving, but it could just be my pc. Just thought I’d let you know. And then if others mention this problem, you could look into it. If it’s just me never mind.

    Thanks.

    PS. Love this page.

    • Hey Nich. I haven’t heard of anyone else having the same issue yet. Sounds like it’s related to the sites caching. What browser are you using?

      • I’m using Chrome primarily. But just checked and all my browsers seem stuck on the 28th.

        • Yeah that is a bit strange. I use Chrome as well and have never encountered that problem. Also tested with Edge and the latest posts where on the home page. Will do some more digging to see if I can nail the issue.

          • dasco144

            If it helps I am definitely getting the same issue, but I am using Opera. Usually a Control + F5 will sort it out. It does come back when I come back to the site later though.

          • How often does it happen? I’ve made some changes so let me know if the issue persists.

          • dasco144

            Was happening every time I came to the site (maybe 2-3 times a day). Started happening the last 1 or 2 days.

          • Thanks for looking into this. I’m still stuck on the 28th at the moment. But I will delete my cookies again and see if it comes back.

          • I was able to replicate the issue in Chrome’s Incognito mode this morning. So I’ve made some more changes to the sites cache. Please let me know if the problem still appears when you clear your cookies.